Continued System Issues - upload / print / tagging / deleting, archiving & routing items
Incident Report for Updox
Resolved
We’re happy to report that the Updox Inbox issues have been resolved and all Updox systems are fully operational. If you are still experiencing any issues or have follow-up questions, please contact us at support@updox.com, 1-866-MyUpdox or 614-600-3048, ext 2, or live support chat at www.updox.com/support.
Posted Jul 10, 2019 - 19:47 EDT
Investigating
We are again investigating reports of continued system issues with the Updox Inbox. We are working to resolve this issue and appreciate your continued patience.
Posted Jul 10, 2019 - 16:45 EDT
This incident affected: Updox.