Power outage at Updox Office
Incident Report for Updox
Resolved
The power has returned to the Updox Office. Phones are now functioning. Thank you for your patience.
Posted May 13, 2019 - 17:05 EDT
Investigating
Due to a power outage at the updox office. The full support center is currently offline. Please email your support issues to support@updox.com and we return the messages once power is restored. We will also update the status page when we have more information.
Posted May 13, 2019 - 16:22 EDT
This incident affected: Updox.