Fax Delays
Incident Report for Updox
Resolved
We’re happy to report that we have resolved the issue that caused the fax delays. If you are still experiencing any issues or have follow-up questions, please contact us at support@updox.com, 1-866-MyUpdox or 614-600-3048, ext 2, or live support chat at www.updox.com/support.
Posted May 14, 2019 - 16:16 EDT
Investigating
We are currently experiencing delays with our inbound and outbound faxing and "Sent Items" are not being created for outbound faxes. Our Engineering Team is working on the issue. We apologize for any inconvenience this causes to your business and will keep you updated on our progress.
Posted May 14, 2019 - 14:43 EDT
This incident affected: Updox.