Continued System Issues - upload / print / tagging / deleting, archiving & routing items
Incident Report for Updox
Resolved
We’re happy to report that the Inbox issues have been resolved and all Updox systems are fully operational. If you are still experiencing any issues or have follow-up questions, please contact us at support@updox.com, 1-866-MyUpdox or 614-600-3048, ext 2, or live support chat at www.updox.com/support.
Posted Jul 10, 2019 - 14:51 EDT
Identified
Corrected Status: We are continuing to work to resolve the issues seen in the Updox Inbox today. We will update as we learn more from our Engineering Team.
Posted Jul 10, 2019 - 12:42 EDT
Monitoring
We’ve resolved the issues with Updox Inbox functionality and will closely monitor throughout the day. If you are still experiencing any issues or have follow-up questions, please contact us at support@updox.com, 1-866-MyUpdox or 614-600-3048, ext 2, or live support chat at www.updox.com/support.
Posted Jul 10, 2019 - 09:21 EDT
Investigating
We are currently investigating reports of Updox Inbox issues - users are not successful when they upload / print / tag / delete & archive items. Our Engineering Team is working on the issue. We apologize for any impact this causes to your business and will keep you updated on our progress.
Posted Jul 10, 2019 - 08:43 EDT
This incident affected: Updox.