Updox Fax Delays

Incident Report for Updox

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 13:00 EDT

Monitoring

The cause of the delays has been determined and our carrier has implemented a solution. We will continue to monitor for a full resolution.
Posted Mar 18, 2026 - 12:01 EDT

Update

The cause of the delays has been determined and our carrier has implemented a solution. We will continue to monitor for a full resolution.
Posted Mar 18, 2026 - 11:59 EDT

Update

We are continuing to investigate this issue.
Posted Mar 18, 2026 - 11:58 EDT

Update

We are continuing to investigate this issue.
Posted Mar 18, 2026 - 11:35 EDT

Investigating

We are experiencing a disruption of service with Updox Fax. We are working with our carrier to restore services as quickly as possible. You may experience issues with inbound fax delays or inability to retrieve fax confirmation pages. Updates will be provided as soon as they become available.
Posted Mar 18, 2026 - 10:41 EDT
This incident affected: Fax.