Login Issues - Practice Fusion Users
Incident Report for Updox
Resolved
We’re happy to report that Practice Fusion resolved their log in issues. Updox systems continue to be fully operational. If you are still experiencing any issues or have follow-up questions, please contact us for live support chat at www.updox.com/support.
Posted Apr 09, 2020 - 13:55 EDT
Identified
Practice Fusion users are currently unable to log in to Updox. We are in close contact with the Practice Fusion Team as they work to resolve the issue. We apologize for any inconvenience this causes to your business and will keep you updated on our progress.
Posted Apr 09, 2020 - 13:18 EDT
This incident affected: Updox.