Service Degradation

Incident Report for Updox

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 13:42 EDT

Monitoring

We are currently experiencing a service disruption. Users may notice delays in sending and receiving faxes, slower performance when uploading files or attaching documents, and delays when printing.

We expect these issues to be resolved within the next 90 minutes and will provide an update once normal service is restored.
Posted Oct 10, 2025 - 12:24 EDT
This incident affected: Updox and Fax.