Slowness
Incident Report for Updox
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 13:20 EDT
Monitoring
We have implemented a fix for the slowness issue and the issue is resolved. We will continue to monitor. If there are no additional occurrences, the status of this incident will be moved to resolved in 30 minutes.
Posted Apr 17, 2024 - 12:54 EDT
Update
Our team continues to investigate the slowness within the Updox inbox and will continue to provide updates every 30 minutes. Thank you for your patience.
Posted Apr 17, 2024 - 12:33 EDT
Update
Our team continues to investigate the slowness within the Updox inbox and will continue to provide updates every 30 minutes. Thank you for your patience.
Posted Apr 17, 2024 - 12:00 EDT
Identified
Updox has identified that some users may experience slowness within the Updox inbox. We are investigating the issue and will post updates every 30 minutes.
Posted Apr 17, 2024 - 11:33 EDT
This incident affected: Updox and Fax.