Updox with Practice Fusion - Login
Incident Report for Updox
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 11:26 EDT
Identified
Practice Fusion users: When accessing Updox and you receive a message that your account cannot be found or to contact support, please try the following steps:
1. In Practice Fusion: Click Log out.
2. Close the browser window.
3. Re-open the browser window.
4. Go to myupdox.com and click on Practice Fusion.
5. Sign in with Practice Fusion.
6. Enter your Practice Fusion login credentials and click Log in.
Posted Sep 13, 2022 - 11:36 EDT
This incident affected: Updox.